Customer Care Message

Export & Backup Guide
Welcome to the WebOffice and WorkSpace export and backup guide. This guide provides an overview and requirements of the tools
available to extract data from your WebOffice or WorkSpace site. This documentation is intended for Administrators and Members of
WorkSpace or WebOffice sites. The level of expertise required will range from easy to use to moderate difficulty depending on the tool
being used. This document also provides a definition of tools and explains which tool to use in different scenarios.
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I.

EXPORT & BACKUP OPTIONS

WebOffice/ Workspace services have several types of export tools that enable both Members and Administrators to transfer data off of
their site. These are the most common ways to backup or remove data.
The main difference between Member and Admin export capabilities is the permission-level to certain data types:
Members have the ability to:
•
Export their “personal” data, such as their personal Contacts, Calendar, Discussions, Polls, Expense Reports and
Tasks.
•
Export specific Database views if they have permission to the database view.
•
Download their Personal documents and any Group documents they have permission to access.
Admins have the ability to:
•
Export group data, such as group Discussions, Polls, and Tasks and all Databases, regardless of permissioned
access.
Note: It is recommended that individual users download their own expense reports and tasks.
What’s new this year is that we have added an Export function to several applications on the service:
•
Calendar
•
Expense Reports
•
Discussion
•
Polls
•
Tasks
Below is a matrix of available Export and Backup Tool options on the suite of applications:
Application
Export
Other
Backup Tool
(New)
Calendar
x
Contacts
x
Discussions
x*
x**
Database
x*
x
Group Documents
Web Folders
x
Public Documents
Web Folders
x
Personal Documents
Web Folders
x
Expense Reports
x
Polls
x
Tasks
x
WebEx Meeting
x
(Usage Details)
*Discussions & Database Export tool does not download attachments
**The Discussions backup tool only backs up discussion attachments.
Tool notes:
Export tool notes: All export tools will generate a real-time file in the format of your choosing: CSV or TXT. CSV files can be viewed in
a spreadsheet editing application such as Microsoft Excel.
Backup tool notes: All backup tools will generate a password protected 7-Zip file that is stored on the FTPS server. Backup requests
are not immediate; the time it takes to process the backup request will vary based the amount of content being backed up and server
load. Database backups will include all database columns and database attachments. Document backups will include all documents
stored in the selected repository. Database backups include a text file that displays which attachments belong to which database
records. Document backups include a text file that you can use to correlate the numbered folders to the original directory structure. It is
recommended that this text file be viewed in a spreadsheet editing application, such as Microsoft Excel.

Definition of Tools
Tool name
Calendar Export

Contact Export

Who can
use the tool
Members &
Admins

Members &
Admins

Tool Definition
This tool exports all visible calendar entries in the current view. For
example, if you are looking at the weekly calendar, all visible items for
the week will be exported.
This tool exports all contacts visible to your account on the Contacts
page.
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Discussions Export

Members &
Admins

The Discussions Export tool will export all visible forums and
responses. Note that this tool does not export discussion attachments.
An administrator can backup discussion attachments by navigating to
the Documents section of the site and clicking the Backup button.
Once on the Document Backup page, check the Discussions box and
then click the Backup button.

Database Export

Members &
Admins

The Database Export tool will export the current database view.
Columns that are not visible in the currently selected view and
database attachments will not be exported.

Database Backup

Admins

This tool should be used to backup an entire database including all
database attachments. The Database Backup tool will start a job to
create a 7-Zip file on the FTPS server containing the entire selected
database and all items attached to the database. Each database will
be contained in a separate 7-Zip file.

Documents Backup

*Members &
Admins

Members can only backup their personal documents using this tool. An
admin may backup their personal documents, and all Public & Group
documents on the site. The Documents Backup tool will start a job to
create a 7-Zip file on the FTPS server containing the selected
documents. Each document backup (Group/Public/Personal) will be a
separate 7-Zip file. Note that Document Backups will not retain the
original folder structure. If you would like to export your documents and
retain the original folder structure, download your documents via Web
Folders

Documents (Web Folders)

Members &
Admins

Expense Reports Export

Members &
Admins

Members can download all of their personal documents and any public
or group documents they have permission to access. Admins can
download all of their personal documents and all of the group and
public documents on the site. For steps to setup Web Folders for your
operating system, refer to the following Knowledge Base article:
http://kb.webex.com/WBX27436. Documents can be downloaded in
real-time once Web Folders have been setup.
The Expense Reports export tool will export a file containing all
Expense Reports visible to your account.

Polls Export

Members &
Admins

The Polls export tool will export a file containing all Polls visible to your
account.

Tasks Export

Members &
Admins

The Tasks export tool will export a file containing all Tasks visible to
your account.

WebEx Meetings Usage

Members &
Admins

A WebEx Meeting Usage Report provides information about past
meetings you’ve held. To generate a Usage Report, navigate to the
WebEx Meetings section of your site, then select Options > Reports.
On the Usage Reports page, enter a date range, select a method to
sort by, then click the Display Reports button.

II.

BACKUP TOOL (NEW)

WHAT’S NEW: Backup Tool for WebOffice/Workspace
Thanks to your past requests, WebOffice/Workspace services can now provide a more robust self-service backup option for its
most popular applications – Documents, Database, and Discussion Attachments – one that’s more suitable for larger, more
complex data export needs.
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If you have a large database or whole set of databases that needs all records backed up, or have too many files and folders in
your Documents section that make the more traditional Web Folders file transfers a challenge, then the “new” Backup Tool
for WebOffice / Workspace using an FTPS client may be your preferred data export/backup solution.
Who can use the backup tool?
To ensure that your backup needs follow similar permission structures on your WebOffice applications, for any sitelevel data backup, such as all Group folders or all records on a given database, only Administrators may have this
level of access.
How technical do I need to be?
The backup tools require moderate technical expertise and are intended for administrators. For each recommended
FTPS clients, step-by-step instructions are supplied in this guide.
We recommend that you read through this guide carefully and read our Backup FAQ section.

What you need to get started using the new tool

rd

In order to take advantage of the new Backup Tool feature, you will need to download & install a 3 party FTPS client.
rd
If you are not comfortable using 3 party FTP software (or have policies that restrict the use of FTPS clients on your
network), then we don’t recommend you take this route for backup.
The available Export/Web Folder tools discussed in Section I. are the most commonly used data export options.
Recommended FTPS Clients
To support secure file transfer over FTPS, Cisco WebEx recommends the following FTPS clients:
WinSCP
FileZilla for Windows
FileZilla for Mac
These are free, open-source FTPS clients that are readily available on the web for download. Refer to the Setting Up &
Configuring FTPS Clients portion of this document for additional information.
Important: Please be fully aware that Cisco doesn’t own or support these recommended FTP clients.

Initiating the Backup Request on your site
1. Login to your WebOffice/ Workspace site.
2. Navigate to the application that you want to backup:
•
Documents (Note: Discussion attachments can be downloaded from the Documents Backup page)
•
Database
3. Click on the Backup button.

4. Select among the checkbox options for backup – optional selections
If Documents or Discussions-- select Group, Personal, Public, Discussions, or all items
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If Database -- select the Database(s) you want to backup, or all items
5. Click the Backup button.

This starts the server-based backup job, and the page will now show “Pending” status in the backup status
field. After submitting the request it is ok to navigate away from the page and do other activities on your site.
Note: No backup files will be downloadable from your site; this is where having the FTP client installed on
your PC or Mac is an important next step.
6. Use one methods below to check the backup job status:
a) “Backup Status” field on the table will start with a Pending Status and then move to “Success” if the job is
successfully completed.
b) You’ve received a backup confirmation from notify@webexone.com
Once you see the job is successful or you’ve received backup confirmation email, you are ready to go to the
next section.
Special Note: The expected amount of time for backup jobs to be completed will vary based on a number of factors:
a) the size of your backup job
# files/ total size of files
# databases / # records on database, etc
b) the aggregate volume of similarly requested jobs being made by other WebOffice customers at the same
time (known as server load)
To help offset potential server load during peak periods, we are limiting the number of backup job requests for the
same content (i.e. database ABC) to once every 7 days. To check when you can perform the next backup, navigate
to the Backup page. For Database backups, the days remaining before you can initiate another backup is listed in the
Backup Request Submitted column. For Document and Discussion Attachment backups, this days remaining before
another backup can be initiated is listed in the Backup Submitted At column. The calendar
icon will list the
number of days left before you can initiate another backup. Mousing over this icon will display the exact time you can
start another backup.

III.

Setting Up & Configuring FTPS Clients

a. WinSCP
WinSCP is freeware supporting three file transfer protocols; SFTP, FTP and SCP. SFTP and SCP use SSHs FTP (SSH File Transfer
Protocol), SCP (Secure Copy) client for Windows using SSH (Secure Shell). Its main function is safe copying of files between a local
and a remote computer.

Client Installation Requirements
WinSCP runs on Microsoft Windows 2000 and newer, up to Windows 8/Windows Server 2012. It runs both on client and server editions
of Microsoft Windows. Documentation and frequently asked questions can be found at http://winscp.net/eng/docs/start.

Downloading the WinSCP Client
To download the WinSCP client, navigate to http://download.cnet.com/WinSCP/3000-2160_4-10400769.html and click the Download
Now button. You should save the installer to an easily accessible location such as your Microsoft Windows desktop or your My
Documents folder.

Customer Care Message
Installing WinSCP
Note: An online installation guide for WinSCP can be found at http://winscp.net/eng/docs/installation.
1.

Open the installation program by double clicking on it’s icon.
•

Note: Your computer might display a security warning prior to installation. Click Run to start the installation.

2.

Select the installation language that you wish to use.

3.

Review the Welcome and License Agreement screens and click Next.

4.

Select a setup type. For basic setup, choose Typical Installation.

5.

You will be prompted for Initial User Settings. This mainly allows users to select their preferred user interface style. The
Explorer interface is recommended for first time users of WinSCP. For users who are familiar with file managers like Total
Commander, Servant Salamander or Norton Commander, it is recommended that you keep the default Commander Interface.
Initial User Settings can be changed later.

6.

After selecting the interface, the Ready to Install screen opens. On this screen, you can review the installation options you
have selected. Click Install to start the installation process.

7.

A brief installation process will take place. You may have to restart your computer. If you choose not to restart, some WinSCP
functions may not be available until you do so. When installation is complete, a WinSCP icon will appear on your desktop.

WinSCP Quick Start
1. Double-click the WinSCP icon on your computer’s desktop to launch the WinSCP client.
2. WinSCP will prompt you for your login information. The first time that you login, you will only need to enter the Host name, your
FTPS user name, password and select the server’s protocol (FTPS). This information will be stored within the client the next
time you launch WinSCP.
•
•
•
•
•

File Protocol: FTP
Encryption: SSL/TLS Implicit encryption
Host Name: secureftp1.webexone.com
Port number: 990
User name: (Refer to the Database or Documents backup page to obtain your username. See the example admin username below.)

•

Password: Your WebOffice/Workspace account password
WinSCP Login window
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3.
4.
5.

6.
7.
8.

Click the Save button, then enter a name for the connection.
Optionally, check the Save password (not recommended) box.
Click OK.
Next, click Login.
When the warning dialog appears, click the Yes button.
You are now ready to begin using WinSCP to transfer files between the remote server and your local files.
To reconnect to the FTPS server at a later time, open WinSCP, select the entry created for your site, then click the Login
button. If you didn’t opt to have WinSCP store your account password, you will need to enter your WebOffice/WorkSpace
password when connecting.

Transferring Files with WinSCP
After logging in, the data structure of your remote server account will be displayed in the right window. Your local files will appear in the
left window. On the left-side of the window, browse to the folder you would like to save the files to, then drag and drop files from the
remote server to your local file system.

b. FileZilla
FileZilla Client is a free, open source FTP client. It supports FTP, SFTP, and FTPS (FTP over SSL/TLS). The client is available under
many platforms, binaries for Windows, Linux and Mac OS X are provided. FileZilla comes in three versions. The features of FileZilla can
be reviewed here. An online FileZilla User Guide can be found here.

Client Installation Requirements
FileZilla runs on Windows, Linux/Unix or Macintosh. The executable file will vary depending on the operating system. Documentation
and frequently asked questions can be found at https://wiki.filezilla-project.org/Documentation.

Windows
Downloading FileZilla for Windows
To download the FileZilla client, navigate to https://filezilla-project.org/ and select the “Download FileZilla Client" button. Click the
Download Now button to start downloading the installation file. You should save the installer to an easily accessible location such as
your Microsoft Windows desktop or your My Documents folder.

Installing FileZilla for Windows
Note: An online installation guide for FileZilla can be found at https://wiki.filezilla-project.org/Client_Installation.
1.

Open the installation program by double clicking on its icon.
•
Note: Your computer might display a security warning prior to installation. Click Run to start the installation.
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2.

When the Installation window appears, click the Next button.
•
Note: The installer will prompt you to install one or more optional software(s). Click the Decline button if you do not
want to install the optional software.

3.
4.

The FileZilla setup software will begin downloading.
Decide if you wish to install only for your user account or if FileZilla should be accessible by every user on the machine, then
click Next.
You will be prompted to select the components that you wish to install.
The next window will ask you where to install the program. If you don't have any special requirements, click Next to continue.
You will be asked to name the installation folder for FileZilla shortcuts. The default name "FileZilla FTP Client" should be
acceptable for most users. You may also choose not to install these shortcuts.
Click Install.
Click Finish to close Setup.

5.
6.
7.
8.
9.

FileZilla for Windows Quick Start
1.
2.
3.
4.

Double-click the FileZilla icon on your computer’s desktop to launch the WinSCP client or launch it from the Start menu by
clicking Start > All Programs > FileZilla FTP Client > FileZilla.
Click on the Site Manager Icon or click on the Site Manager option under the File menu.
Click on the New Site button to create a new site profile. Choose a name for the new site. It is just a profile name. It does not
have to match the server name or the directory name.
Select the General Tab and enter the following settings:
•
•
•
•
•
•

Host: secureftp1.webexone.com
Port: 990
Protocol: FTP - File Transfer Protocol
Encryption: Require implicit FTP over TLS
Login Type: Normal
User: (refer to the Database or Documents backup page to obtain your username. See the example admin username below.)

•
•

Password: WebOffice/Workspace account password
Account: leave it blank (default value)
FileZilla login window

5.
6.

Click Connect.
When the Unknown certificate prompt appears, check the Always trust certificate in future sessions box, then click OK.
To reconnect to the FTPS server at a later time, open FileZilla, click File > Site ManagerA, select the entry created for your
site, then click the Connect button.

Transferring Files with FileZilla for Windows
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After logging in, the data structure of your remote server account will be displayed in the right window. Your local files will appear in the
left window. On the left-side of the window, browse to the folder you would like to save the files to, then drag and drop files from the
remote server to your local file system.

Mac
Downloading FileZilla for Mac
To download the FileZilla client, navigate to https://filezilla-project.org/ and select the “Download FileZilla Client" button. Click the
Download Now button to start downloading the installation file.

Installing FileZilla for Mac
•

Go to your Downloads folder and double-click the downloaded file. The software will be automatically installed to your desktop.

FileZilla for Mac Quick Start
1.
2.
3.
4.
5.
6.

Double-click the FileZilla icon on your desktop.
If prompted, click the Open button.
Go to the File menu, then select Site ManagerA.
Click the New Site button.
Enter a name for the connection. The default name is New site.
In the general tab, specify the following information:
•
•
•
•
•
•

Host: secureftp1.webexone.com
Port: 990
Protocol: FTP - File Transfer Protocol
Encryption: Require implicit FTP over TLS
Login Type: Normal
User: (Refer to the Database or Documents backup page to obtain your username. See the example admin username below.)

•
•

Password: WebOffice/Workspace account password
Account: leave it blank (default value)
FileZilla login window
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7.
8.
9.
10.

Click the OK button.
Go to the File menu, then Select Site ManagerA.
Select the connection you just created, then click the Connect button.
When the Unknown certificate prompt appears, check the Always trust certificate in future sessions box, then click OK.
To reconnect to the FTPS server at a later time, click the FileZilla icon on your desktop, navigate to File > Site ManagerA,
select the entry created for your site, then click the Connect button.

Transferring Files with FileZilla for Mac
After logging in, the data structure of your remote server account will be displayed in the right window. Your local files will appear in the
left window. On the left-side of the window, browse to the folder you would like to save the files to, then drag and drop files from the
remote server to your local file system.
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Frequently Asked Questions
•
•

Admin Backup Frequently Asked Questions
Member Backup Frequently Asked Questions

